Hello,

My phone: GSMART Roma R2 (Rooted)

I know there are a lot of threads how to restore IMEI but none of them worked when I dial up *#06#, it shows message with two lines containing "null".
I was using MIUI rom for a while and suddenly after I rebooted phone SIM was no longer recognized (before reboot I was playing with SWAP couldn't make it work so I uninstalled BusyBox (could that cause the issue?))

I already tried:
Engineering Mode: Displays "AT command is failed to send"
Terminal Emulator: Doesn't work
MAUI 3G: Flashing new IMEI changed nothing.
MTK Droid Tool - Changing IMEI did nothing.
SN Writer: Writing new IMEI changed nothing BUT when I choosed to read IMEI it successfully displayed both IMEI in the textbox. (So it looks like the IMEI actually is registered on the phone but phone doesn't seem to use it)
Manually writing MP0B_001 to NVRAM: Nothing changed.

I have used backup in CWM recovery to stock ROM, didn't work, then I did factory reset, didn't work, flashed back the stock recovery and installed update from Gigabyte site, didn't work. So basicly now my phone has stock rom, stock recovery, factory reseted and is rooted.

Thank you very much for any answers because I just fell hopeless about fixing my phone


Hello, My phone: GSMART Roma R2 (Rooted) I know there are a lot of threads how to restore IMEI but none of them worked when I dial up *#06#, it...

More...

Hello,

My phone: GSMART Roma R2 (Rooted)

I know there are a lot of threads how to restore IMEI but none of them worked when I dial up *#06#, it shows message with two lines containing "null".
I was using MIUI rom for a while and suddenly after I rebooted phone SIM was no longer recognized (before reboot I was playing with SWAP couldn't make it work so I uninstalled BusyBox (could that cause the issue?))

I already tried:
Engineering Mode: Displays "AT command is failed to send"
Terminal Emulator: Doesn't work
MAUI 3G: Flashing new IMEI changed nothing.
MTK Droid Tool - Changing IMEI did nothing.
SN Writer: Writing new IMEI changed nothing BUT when I choosed to read IMEI it successfully displayed both IMEI in the textbox. (So it looks like the IMEI actually is registered on the phone but phone doesn't seem to use it)
Manually writing MP0B_001 to NVRAM: Nothing changed.

I have used backup in CWM recovery to stock ROM, didn't work, then I did factory reset, didn't work, flashed back the stock recovery and installed update from Gigabyte site, didn't work. So basicly now my phone has stock rom, stock recovery, factory reseted and is rooted.

Thank you very much for any answers because I just fell hopeless about fixing my phone


Hello, My phone: GSMART Roma R2 (Rooted) I know there are a lot of threads how to restore IMEI but none of them worked when I dial up *#06#, it...

More...