Greetings,

Apologies if this has been asked somewhere else before, but I haven't found it anywhere after hours of searching. I've been trying to get ADB to work on my Kindle Fire HD 7 with no success. I've downloaded many drivers and the Android SDK and Android Studio as well. After installing all different drivers, when I connect the tablet to the laptop and test fastboot connection, I get the following:

C:\android-sdk\platform-tools>fastboot -i 0x1949 getvar product
product: Tate-PVT-08
finished. total time: 0.002s

I believe this is expected when I run this command, which I guess means the fastboot cable is working and perhaps the driver too? (not sure). However, when I run the following ADB commands this is what happens:

C:\android-sdk\platform-tools>adb devices
List of devices attached
(this comes empty, no result)

C:\android-sdk\platform-tools>adb shell
error: device not found
error: device not found

I've tried this in two different laptops and I get the same result on both. Both laptops are running Windows 7 and my tablet is currently running version 7.5.1. Any help would be greatly appreciated. And thanks in advance.


Greetings, Apologies if this has been asked somewhere else before, but I haven't found it anywhere after hours of searching. I've been trying to...

More...

Greetings,

Apologies if this has been asked somewhere else before, but I haven't found it anywhere after hours of searching. I've been trying to get ADB to work on my Kindle Fire HD 7 with no success. I've downloaded many drivers and the Android SDK and Android Studio as well. After installing all different drivers, when I connect the tablet to the laptop and test fastboot connection, I get the following:

C:\android-sdk\platform-tools>fastboot -i 0x1949 getvar product
product: Tate-PVT-08
finished. total time: 0.002s

I believe this is expected when I run this command, which I guess means the fastboot cable is working and perhaps the driver too? (not sure). However, when I run the following ADB commands this is what happens:

C:\android-sdk\platform-tools>adb devices
List of devices attached
(this comes empty, no result)

C:\android-sdk\platform-tools>adb shell
error: device not found
error: device not found

I've tried this in two different laptops and I get the same result on both. Both laptops are running Windows 7 and my tablet is currently running version 7.5.1. Any help would be greatly appreciated. And thanks in advance.


Greetings, Apologies if this has been asked somewhere else before, but I haven't found it anywhere after hours of searching. I've been trying to...

More...